Other Usefull Pages
[ BBS FAQ ] [ Error Codes ] [ Chlorine Info ] [ Bromine Info ] [ TDS ] [ pH Explained ] [ Electric Heater Guide ] [ Voltage Testing ] [ Pump Air Lock ] [ Owners Manuals ]

Ask 'Dr. Spa' Q & A Message Board




Ask 'Dr. Spa' Q & A Message Board archives

Brett Aqualine EM-190 ??

I have a Brett Aqualine EM-190 (about 10 years old) which I am having a little trouble with. This model has a 3 position switch that controls heating and filtering. In one position the “Timer controls filtering, Thermostat controls heating anytime required” . In this position the timer part works, but when timer is off and I turn up the thermostat I would expect both the circulating pump to kick in and the heater light to come on but nothing happens. All other functions work as I expect them to, heating and filtering, etc.

Any ideas on the what the problem is?

Messages In This Thread


Home Page , Wooden Hot Tubs , Japanese Ofuros , Hot Tub & Spa Covers
Info & Help , Hot Tub FAQ , Hot Tub Picture Gallery , Virtual Store

PLEASE NOTE: We are Roberts Hot Tubs Inc. (manufacturers of traditional wooden hot tubs)! If you found this webpage through a search engine while searching for a different brand of spa, we are not them! We simply appeared in your search due to that name being talked about on this particular web page. The phone number below will reach Roberts Hot Tubs, not the manufacturer of the brand of spa you're searching for. This is a public forum and you're more than welcome to post a question asking for contact or other information for a particular brand of spa. Almost certainly someone will be able to assist you.

(510) 234-7920

Register with our confidential mailing
list to receive notices of updates, special
offers and free information.

E-Mail address: 
subscribe unsubscribe